TL-WN722N-Web Upload disconnects Internet

Dear friends. (for italian translation of my message with Google translator please scroll down-per la traduzione italiana del mio messaggio con il traduttore di Google si prega di scorrere verso il basso):

I hope that someone can give my suggestion about my problem. I have TL-WN722N USB Wireless Adapter and have a weird problem. Everything works great besides upload. When I try to upload file over the web (probably those uploads are based on Adobe Flash) Internet disconnects after few minutes (only internet disconnects altough wireless connection with the DSL modem stays connected so I have to reconnect internet) which is not such a problem but then I have to start to upload from the beginning and unfortunately it is impossible to finish the upload.

But when I try to upload over FTP protocol then everything works great without the problem. Does anyone have any suggestions about possible source of problem? Could USB HUB with external acdc adapter maybe solve the problem?

ITALIAN TRANSLATATION with Google Translator:
Cari amici.

Spero che qualcuno possa dare il mio suggerimento del mio problema. Ho TL-WN722N Adattatore USB Wireless e hanno un problema strano. Tutto funziona alla grande, oltre upload. Quando cerco di caricare il file sul web (probabilmente quelli arrivi sono basate su Adobe Flash), Internet si disconnette dopo pochi minuti (solo internet si disconnette anche se la connessione wireless con il modem DSL rimane connesso quindi devo ricollegare internet) che non è un problema ma poi devo iniziare a caricare fin dall’inizio e, purtroppo, è impossibile completare il caricamento.

Ma quando cerco di caricare oltre il protocollo FTP allora tutto funziona alla grande senza il problema. Qualcuno ha qualche suggerimento sulla possibile fonte di problemi? Potrebbe HUB USB con adattatore esterno acdc forse risolvere il problema?

hi :wink:
sorry for my english i hope you can understand everything ^^

first of all, it’s really strange that ftp works well (have you tested upload speed?), while flash based do not.

can you complete a test like this? what results do you get?

please try with different size, and report if the test fails only on bigger ones ^^

first thing I’ll try is using another O.S., like an ubuntu live-cd, so you can find out if it’s a hardware problem or a software problem (drivers, flash plugin).

If (as i think it is) it’s windows or the flash plugin, you can try different browsers like firefox, chrome, internet explorer, that use different version of the flash plugin.

if the problem persist try to update the drivers for the key,
but i think you already have these…

let me know :wink:

I have done some tests and this is the situation.

FTP upload works ok. Megaupload and Adrive uploads are also working fine (I think they are JAVA based but maybe I am wrong).

When I am using for example upload options from

that are


they all fails somehwere after 3 mb. After that wireless internet disconnects (modem stays connected so I have to reconnect).

I will now post replies.

Your english is great :slight_smile:
Thanks so much for the reply.

Those are Upload Speed Test results:
:::… Upload Test Results …:::
Upload Connection is:: 273 Kbps about 0.3 Mbps (tested with 97 kB)
Upload Speed is:: 34 kB/s
Tested From:: (Dallas, TX USA)
Validation Link::
Test Time:: 2011-08-07 11:03:54 Local Time
1MB Upload in 30.12 Seconds - 1GB Upload in ~9 Hours - 5X faster than 56K
Tested from a 97 kB file and took 2.891 seconds to complete
Running at 148% of hosts average (
User Agent:: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB7.1; EasyBits

I have tried different sizes of files (on podomatic but it always fails after aprox 3mb of upload. If the filesize is less then 3mb then upload is sucesful.

Tried different browser IE, GOOGLE CHROME, FIREFOX, SAFARI - always the same results.

I have the recent drivers I downloaded them recently manualy from TPlink site but figuret out that those on the CD were also the last ones.

I will now try with ubuntu. I have a DVD of ubuntu so we will see. Will report.

Best Wishes :slight_smile:

I have done some additonal experiments.

Unfortunately I was not been able to get TPLINK working on UBUNTU as the drivers are developed for Windows. Maybe there are some 3rd party solutions available but didn’t tried to dig further.

Anyway after some test I have tried to upload another audio file on the podcast site here:

And there also works fine and it also says that it uses FLASH UPLOADER. Upload was sucesful.

The problems with uploading are present here:

They are also using FLASH uploaders but after 3mb it disconnects. Strange. Can aynone else try to recreate the problem? Everything else it seems that it is working fine. No problems with download and in that sense works great. (upload works fine on adrive, megaupload, youtube etc

so the problem is ONLY on those sites… really strange!

Sorry for the wrong advice about ubuntu, i forgot that it does not include the ath9k_htc drivers!
You can try with WifiWay 2.0.2, it should include them!

For sure they are included in backtrack, but it’s a lot larger